Delay in Processing Transfers: NIBSS
Incident Report for Sudo
Resolved
Dear Valued Customer,
We hope this message finds you well.

We are pleased to inform you that the delays in processing your transfers, which were due to an issue with NIBSS, have now been resolved. You should be able to process your transfers without any further interruptions.

We sincerely appreciate your patience during this time and apologize for any inconvenience caused. Should you experience any further issues or need assistance, please do not hesitate to contact our customer support team.
Thank you for your continued trust in Safe Haven.

Best regards,
The Safe Haven Team
Posted Sep 11, 2024 - 20:40 BST
Identified
Dear Valued Customer,

We hope this message finds you well.
We would like to inform you that you may be experiencing delays in the processing of your transfers. Please note that this issue stems from NIBSS.

Rest assured, our team is actively communicating with NIBSS to resolve the issue as quickly as possible. We understand the inconvenience this may cause and appreciate your patience during this time.

We will keep you updated on the progress and notify you as soon as the issue is resolved. In the meantime, if you have any urgent concerns or require assistance, please do not hesitate to contact our customer support team.
Thank you for your understanding and continued trust in Safe Haven.

Best regards,
The Safe Haven Team
Posted Sep 11, 2024 - 13:27 BST
This incident affected: Transfers.