Emergency System Maintenance
Incident Report for Sudo
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 14:04 GMT
Identified
We would like to inform you that we are currently conducting emergency maintenance on our system. As a result, you may experience temporary service interruptions.

Our technical team is working diligently to resolve the issue and restore full service as quickly as possible. The estimated resolution time is capped at 2 hours, all things being equal. We will notify you on the progress, and we apologize for any inconvenience this may cause.

We appreciate your understanding and patience during this time.

Thank you for your continued support.
Posted Nov 20, 2024 - 09:48 GMT
This incident affected: Sudo API, Business Dashboard, Physical Cards, Virtual Cards, Virtual Accounts, and Transfers.