Downtime on Naira Card
Incident Report for Sudo
Resolved
This incident has been resolved. We have put all measures to make this issue does not happen again.

Thank you for your patience and understanding.
Posted Apr 04, 2024 - 11:30 BST
Identified
Dear Customers,

We are currently experiencing a temporary interruption in processing Naira Card transactions. We apologize for any inconvenience this may cause. Our team is actively working to resolve the issue and restore normal service as quickly as possible.

Thank you for your patience and understanding.
Posted Apr 03, 2024 - 14:51 BST
This incident affected: Physical Cards.