Temporary Disruption on USD Card Operations
Incident Report for Sudo
Resolved
This incident has been resolved.
Posted Sep 23, 2024 - 10:23 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 23, 2024 - 00:36 BST
Identified
Dear Valued Customer,

We would like to inform you of a temporary service disruption on our dollar platform, which has affected USD card operations.

Our team is actively working with the card provider to resolve the issue. We anticipate full restoration soon and will provide updates in due course.

We apologize for any inconvenience caused and sincerely appreciate your patience.

Thank you for your continued trust in us.

Best regards,
Sudo Team
Posted Sep 23, 2024 - 00:32 BST
This incident affected: Virtual Cards.