Funds Transfer
Incident Report for Sudo
Resolved
This issue has been resolved.
Posted Feb 10, 2024 - 20:13 GMT
Identified
Dear customers,

Please be informed there is currently an issue with the central processor of bank transfers (NIBSS). You may experience some failures while attempting name inquiries/transfers from your Safe Haven account to other bank accounts, via the Dashboard or the API.

We're currently engaging NIBSS to get the issue resolved and would provide updates on resolved.

We apologize for the inconvenience this may cause.
Posted Feb 10, 2024 - 17:35 GMT
This incident affected: Transfers.