Temporary Downtime for USD Card Creation and Funding
Incident Report for Sudo
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 08:51 BST
Identified
Dear Customers,
We are currently experiencing intermittent downtime with our USD Card Creation and Funding services. This issue stems from unexpected technical challenges with our service providers. Please be assured that we are actively working with them to resolve these interruptions as swiftly as possible.
Posted Apr 16, 2024 - 14:05 BST
This incident affected: Virtual Cards.